home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-wireless / madwifi-ng-tools-0.1531.20060427 / madwifi-ng-tools-0.1531.20060427.ebuild < prev    next >
Text File  |  2006-05-02  |  2KB  |  60 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.1531.20060427.ebuild,v 1.1 2006/04/27 16:29:28 brix Exp $
  4.  
  5. inherit toolchain-funcs
  6.  
  7. MY_P=${PN/-tools/}-r${PV:2:4}-${PV:7:8}
  8. S=${WORKDIR}/${MY_P}
  9.  
  10. DESCRIPTION="Next Generation tools for configuration of Atheros based IEEE 802.11a/b/g wireless LAN cards"
  11. HOMEPAGE="http://www.madwifi.org/"
  12. SRC_URI="http://snapshots.madwifi.org/madwifi-ng/${MY_P}.tar.gz"
  13.  
  14. LICENSE="|| ( BSD GPL-2 )"
  15. SLOT="0"
  16. KEYWORDS="~amd64 ~ppc ~x86"
  17.  
  18. IUSE=""
  19. DEPEND="virtual/libc"
  20. RDEPEND="!net-wireless/madwifi-old-tools
  21.         ${DEPEND}"
  22.  
  23. src_unpack() {
  24.     unpack ${A}
  25.  
  26.     # format string fix from solar
  27.     sed -i \
  28.         -e 's:err(1, ifr.ifr_name);:err(1, "%s", ifr.ifr_name);:g' \
  29.         ${S}/tools/athstats.c || die
  30.  
  31.     sed -i \
  32.         -e "s:CC =.*:CC = $(tc-getCC):" \
  33.         -e "s:CFLAGS=:CFLAGS+=:" \
  34.         -e "s:LDFLAGS=:LDFLAGS+=:" \
  35.         ${S}/tools/Makefile || die
  36. }
  37.  
  38. src_compile() {
  39.     emake tools || die "emake tools failed"
  40. }
  41.  
  42. src_install() {
  43.     make DESTDIR="${D}" BINDIR=/usr/bin MANDIR=/usr/share/man STRIP=echo \
  44.         install-tools || die "make install-tools failed"
  45.  
  46.     dodir /sbin
  47.     mv "${D}"/usr/bin/wlanconfig "${D}"/sbin
  48. }
  49.  
  50. pkg_postinst() {
  51.     if [ -e "${ROOT}"/etc/udev/rules.d/65-madwifi.rules ]; then
  52.         ewarn
  53.         ewarn "The udev rules for creating interfaces (athX) are no longer needed."
  54.         ewarn
  55.         ewarn "You should manually remove the /etc/udev/rules.d/65-madwifi.rules file"
  56.         ewarn "and either run 'udevstart' or reboot for the changes to take effect."
  57.         ewarn
  58.     fi
  59. }
  60.